• PHP 8.2
    • Laravel Framework 10.48.3
  • MySQL 8.0
  • nginx 1.2
  • Docker


composer require laravel/breeze --dev
[16-Mar-2024 10:09:35 Asia/Tokyo] Xdebug: [Step Debug] Could not connect to debugging client. Tried: host.docker.internal:9000 (through xdebug.client_host/xdebug.client_port).
Using version ^2.0 for laravel/breeze
./composer.json has been updated
Running composer update laravel/breeze
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires laravel/breeze ^2.0 -> satisfiable by laravel/breeze[v2.0.0].
    - laravel/breeze v2.0.0 requires illuminate/console ^11.0 -> found illuminate/console[v11.0.0, ..., v11.0.7] but these were not loaded, likely because it conflicts with another require.

You can also try re-running composer require with an explicit version constraint, e.g. "composer require laravel/breeze:*" to figure out if any version is installable, or "composer require laravel/breeze:^2.1" if you know which you need.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.




// 実行コマンド
composer show laravel/breeze --all | less
// 結果
versions : dev-master, 2.x-dev, v2.0.0, 1.x-dev, * v1.29.1, v1.29.0, v1.28.3, v1.28.2, v1.28.1, v1.28.0, v1.27.0, v1.26.3, v1.26.2, v1.26.1, v1.26.0, v1.25.1, v1.25.0, v1.24.1,
 v1.24.0, v1.23.3, v1.23.2, v1.23.1, v1.23.0, v1.22.0, v1.21.2, v1.21.1, v1.21.0, v1.20.2, v1.20.1, v1.20.0, v1.19.2, v1.19.1, v1.19.0, v1.18.2, v1.18.1, v1.18.0, v1.17.0, v1.1
6.1, v1.16.0, v1.15.4, v1.15.3, v1.15.2, v1.15.1, v1.15.0, v1.14.3, v1.14.2, v1.14.1, v1.14.0, v1.13.1, v1.13.0, v1.12.0, v1.11.4, v1.11.3, v1.11.2, v1.11.1, v1.11.0, v1.10.0, 
v1.9.4, v1.9.3, v1.9.2, v1.9.1, v1.9.0, v1.8.2, v1.8.1, v1.8.0, v1.7.3, v1.7.2, v1.7.1, v1.7.0, v1.6.1, v1.6.0, v1.5.0, v1.4.3, v1.4.2, v1.4.1, v1.4.0, v1.3.2, v1.3.1, v1.3.0, 
v1.2.3, v1.2.2, v1.2.1, v1.2.0, v1.1.8, v1.1.7, v1.1.6, v1.1.5, v1.1.4, v1.1.3, v1.1.2, v1.1.1, v1.0.4, v1.0.3, v1.0.2, v1.0.1, v1.0.0, v0.1.0, v0.0.6, v0.0.5, v0.0.4, v0.0.3, 
v0.0.2, v0.0.1, dev-chore/adjusts-workflow, dev-typescript


less の結果から1.x 系の最新を選択してインストールする

composer require laravel/breeze:^1.29.1 --dev